summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Benkard <code@mail.matthias.benkard.de>2008-01-27 12:51:01 +0100
committerMatthias Benkard <code@mail.matthias.benkard.de>2008-01-27 12:51:01 +0100
commitf228c3f21021ccbe216d4aa8485f99295d44f4d9 (patch)
treed9a7a4fec438474a9ac84f3449b6f73a50f6bc14 /configure.ac
parentd382b23ee73dd993e944bd4fad9d190bc2e6f849 (diff)
Do not bother looking for ffi.h if libffi cannot be found.
darcs-hash:788678e11c9fb3e49d5906747cbf7f94319e872b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c79078a..6fac92b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,9 @@ AC_PROG_MAKE_SET
AC_SEARCH_LIBS([ffi_call], [ffi], [HAVE_LIBFFI=1; break], [HAVE_LIBFFI=0])
HAVE_ANY_FFI_H=0
-AC_CHECK_HEADERS([ffi.h ffi/ffi.h], [HAVE_ANY_FFI_H=1; break])
+if test x$HAVE_LIBFFI = x1; then
+ AC_CHECK_HEADERS([ffi.h ffi/ffi.h], [HAVE_ANY_FFI_H=1; break])
+fi
AC_SUBST(HAVE_ANY_FFI_H)
AC_SUBST(HAVE_LIBFFI)