summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Benkard <code@mail.matthias.benkard.de>2008-01-27 12:46:11 +0100
committerMatthias Benkard <code@mail.matthias.benkard.de>2008-01-27 12:46:11 +0100
commitd382b23ee73dd993e944bd4fad9d190bc2e6f849 (patch)
tree9cbdbf4f31d13dc2def8dec81153f74ec4580e99 /configure.ac
parenta93c3679f769423c69fca20fab3bb4ade7207cc1 (diff)
Do not build our own libffi if we can find one installed on the system.
darcs-hash:98186d9dca2682cb70a25403ee7415dcbd28249c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c79078a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,36 @@
+## Objective-CL, an Objective-C bridge for Common Lisp.
+## Copyright (C) 2008 Matthias Andreas Benkard.
+##
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, either version 3 of the License, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_PREREQ(2.61)
+AC_INIT(Objective-CL, 0.0.3, objcl-bugs@matthias.benkard.de)
+AC_CONFIG_SRCDIR([Objective-C/libobjcl.h])
+
+AC_PROG_CC
+AC_PROG_OBJC
+#AC_PROG_INSTALL
+#AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
+AC_SEARCH_LIBS([ffi_call], [ffi], [HAVE_LIBFFI=1; break], [HAVE_LIBFFI=0])
+
+HAVE_ANY_FFI_H=0
+AC_CHECK_HEADERS([ffi.h ffi/ffi.h], [HAVE_ANY_FFI_H=1; break])
+
+AC_SUBST(HAVE_ANY_FFI_H)
+AC_SUBST(HAVE_LIBFFI)
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([config.make])
+AC_OUTPUT