summaryrefslogtreecommitdiff
path: root/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'build.gradle')
-rw-r--r--build.gradle21
1 files changed, 18 insertions, 3 deletions
diff --git a/build.gradle b/build.gradle
index 3537b8d..3ab28f4 100644
--- a/build.gradle
+++ b/build.gradle
@@ -2,7 +2,9 @@ plugins {
id 'scala'
id 'java'
id 'io.quarkus'
- id "com.diffplug.gradle.spotless" version "3.27.0"
+ id "com.diffplug.gradle.spotless" version "${spotlessPluginVersion}"
+ id "com.github.ben-manes.versions" version "${versionsPluginVersion}"
+ id "se.patrikerdes.use-latest-versions" version "${useLatestVersionsPluginVersion}"
}
sourceCompatibility = 11
@@ -32,6 +34,14 @@ repositories {
mavenCentral()
}
+tasks {
+ dependencyUpdates {
+ checkConstraints = true
+ gradleReleaseChannel = "current"
+ revision = "release"
+ }
+}
+
dependencies {
implementation enforcedPlatform("${quarkusPlatformGroupId}:${quarkusPlatformArtifactId}:${quarkusPlatformVersion}")
@@ -65,12 +75,17 @@ dependencies {
//implementation 'org.jboss.spec.javax.xml.bind:jboss-jaxb-api_2.3_spec'
//implementation 'jakarta.persistence:jakarta.persistence-api'
- implementation 'org.scala-lang:scala-library:2.13.1'
+ implementation 'org.scala-lang:scala-library'
- implementation 'com.vladmihalcea:hibernate-types-52:2.9.0'
+ implementation 'com.vladmihalcea:hibernate-types-52'
testImplementation 'io.quarkus:quarkus-junit5'
testImplementation 'io.rest-assured:rest-assured'
+
+ constraints {
+ implementation "org.scala-lang:scala-library:${scalaVersion}"
+ implementation "com.vladmihalcea:hibernate-types-52:${hibernateTypesVersion}"
+ }
}
spotless {