summaryrefslogtreecommitdiff
path: root/build.gradle
diff options
context:
space:
mode:
authorMatthias Andreas Benkard <code@mail.matthias.benkard.de>2020-01-18 12:48:40 +0100
committerMatthias Andreas Benkard <code@mail.matthias.benkard.de>2020-01-18 12:48:40 +0100
commite5f81e5ab1f771f03ecbe5192ce66c2ffc11056e (patch)
tree6942b5c2d07640464956d9aab632b6f87a926a38 /build.gradle
parent5d71a9e103889351464bd129e6f4274ca19b44dc (diff)
Clean up build file.
Change-Id: I4d5e82512871398355dccd7c1f97b505cf6e1c9a
Diffstat (limited to 'build.gradle')
-rw-r--r--build.gradle21
1 files changed, 7 insertions, 14 deletions
diff --git a/build.gradle b/build.gradle
index 5a7d9c2..60c2925 100644
--- a/build.gradle
+++ b/build.gradle
@@ -26,26 +26,26 @@ dependencies {
implementation enforcedPlatform("${quarkusPlatformGroupId}:${quarkusPlatformArtifactId}:${quarkusPlatformVersion}")
implementation 'io.quarkus:quarkus-agroal'
- //implementation 'io.quarkus:quarkus-elytron-security'
- //implementation 'io.quarkus:quarkus-elytron-security-jdbc'
- //implementation 'io.quarkus:quarkus-elytron-security-oauth2'
implementation 'io.quarkus:quarkus-flyway'
implementation 'io.quarkus:quarkus-hibernate-orm-panache'
implementation 'io.quarkus:quarkus-hibernate-validator'
implementation 'io.quarkus:quarkus-jdbc-postgresql'
implementation 'io.quarkus:quarkus-jsonb'
implementation 'io.quarkus:quarkus-jsonp'
- //implementation 'io.quarkus:quarkus-keycloak-authorization'
implementation 'io.quarkus:quarkus-kubernetes'
implementation 'io.quarkus:quarkus-mailer'
- //implementation 'io.quarkus:quarkus-oidc'
- //implementation 'io.quarkus:quarkus-quartz'
implementation 'io.quarkus:quarkus-qute'
implementation 'io.quarkus:quarkus-resteasy'
implementation 'io.quarkus:quarkus-resteasy-jsonb'
implementation 'io.quarkus:quarkus-resteasy-qute'
- implementation 'io.quarkus:quarkus-scala'
implementation 'io.quarkus:quarkus-scheduler'
+
+ //implementation 'io.quarkus:quarkus-elytron-security'
+ //implementation 'io.quarkus:quarkus-elytron-security-jdbc'
+ //implementation 'io.quarkus:quarkus-elytron-security-oauth2'
+ //implementation 'io.quarkus:quarkus-keycloak-authorization'
+ //implementation 'io.quarkus:quarkus-oidc'
+ //implementation 'io.quarkus:quarkus-quartz'
//implementation 'io.quarkus:quarkus-smallrye-fault-tolerance'
//implementation 'io.quarkus:quarkus-smallrye-health'
//implementation 'io.quarkus:quarkus-smallrye-metrics'
@@ -55,8 +55,6 @@ dependencies {
//implementation 'org.jboss.spec.javax.xml.bind:jboss-jaxb-api_2.3_spec'
//implementation 'jakarta.persistence:jakarta.persistence-api'
- implementation 'org.scala-lang:scala-library'
-
implementation 'org.mapstruct:mapstruct'
compileOnly 'org.mapstruct:mapstruct-processor'
@@ -71,7 +69,6 @@ dependencies {
testImplementation 'io.rest-assured:rest-assured'
constraints {
- implementation "org.scala-lang:scala-library:${scalaVersion}"
implementation "com.vladmihalcea:hibernate-types-52:${hibernateTypesVersion}"
implementation "org.mapstruct:mapstruct:${mapstructVersion}"
compileOnly "org.mapstruct:mapstruct-processor:${mapstructVersion}"
@@ -82,10 +79,6 @@ dependencies {
}
spotless {
- scala {
- scalafmt()
- }
-
java {
googleJavaFormat()
removeUnusedImports()